Главная страница статей --> Хитрости при программировании php, заметки по базам данных

Текст из воды

Источник: realcoding.net

Step 1
Создайте документ и напишите любой текст. Растеризуйте слой.



Используя кисть, добавьте несколько капель и подтеков к тексту. Объедините оба слоя Layer > Flatten Image.



Step 2
Идем в палитру каналов и создаем маску канала путем перетаскивания любого слоя Red, Green или Blue на иконку New Channel внизу палитры каналов. Называем его water. Далее инвертируем канал Image > Adjust > Invert или Ctrl +I. Получается белый текст на черном фоне.



Step 3
Создаем фон для нашего текста. Сделаем нечто напоминающее воду в бассейне. Создаем новый документ. Включаем сетку View > Show Grid, что бы использовать направляющие. Убедитесь, что Snap To Grid включен в меню View Menu (View>Snap To Grid).
Используя Marquee Tool рисуем квадраты и заливаем выделенную область цветом. Здесь выбрано два цвета светлый (foreground color) со значениями RGB 0,102,153 и темный - RGB 0,51,102.



Далее выделите весь фон Select > All или Ctrl+A и сохраните рисунок как узор Edit > Define Pattern. Вернитесь в документ с водяными буквами и выделите background layer в палитре слоев. Залейте этот слой новым узором Edit>Fill. Use – Pattern, Blending выберите Opacity: 100% и Mode – Normal



Step 4
Сделайте слой с буквами невидимым. Вдохнем немного жизни в наш узор. Используем Filter > Render > Lighting Effects. Это придаст более реалистичный вид. Передвиньте световую направляющую в левый верхний угол как на рисунке или по вашему желанию, со следующими значениями: Intensity – 15, Focus – 71, Gloss - Shiny, Material - Metallic, Exposure – 0 и Ambience - 50. И здесь использован Red как Texture Channel.



Step 5
Вернемся к тексту. Скопируем наш water канал как делали в шаге 2. Переименуем канал в water 2. Сделайте новый канал активным ,придадим ему текучесть. Откроем Filter > Blur > Guassian Blur, радиус установим на 6 пикселей и нажимаем ОК. Далее открываем Image > Adjust > Levels или Ctrl+L) и настраиваем Input Levels - 36,1.00,54. Это придаст резкости изображению.



Step 6
Создаем новый слой Layer > New > Layer или Shift+Ctrl+N. именуем его water и ставим Opacity - 100% и Mode – Normal. Заливаем слой белым цветом. Далее загружаем канал water 2 как выделение: открываем Select > Load Selection и выбираем канал water 2 или в палитре каналов перетаскиваем канал на иконку Load Channel As Selection’. Появляется слово, выделенное пунктиром.
Когда выделение загружено, выберите слой water как активный. Установите черный цвет в качестве Foreground Color и залейте выделение этим цветом. Уберите выделение Select > Desеlect or Ctrl+D. На белом фоне у вас должны быть черные буквы



Step 7
Придадим более объемный вид нашим буквам. Открываем Filter > Blur > Guassian Blur и размываем water слой. Радиус ставим на 6 пикселей. Затем открываем Filter > Stylize > Emboss) со следующими параметрами: Angle: - 45, Height: 6 и Amount: 100%.



Нужно добавить легкие края водяному объекту. Для этого загружаем канал water 2 как в шаге 6. инвертируем выделение Select > Inverse или Shift+Ctrl+I. Используя Feather Selection Tool смягчим - Select > Feather или Alt+Ctrl+D и используя Feather Radius – 2 нажимаем ОК. выбираем foreground color черный и заливаем выделение Alt+Backspace. Не снимаем выделение! Сначала открываем Filter > Fade или Shift+Ctrl+F и устанавливаем 50% Opacity и Normal Blend. Теперь снимаем выделение Ctrl+D or Select > Deselect.



Step 8
Откройте Image > Adjust > Curves or Ctrl+M. Установите следующие значения: Input - Output Levels - 0-0, 50-64, 64-111, 128-128, 192-195, 214-195, 255-255.



Далее добавим немного объема по краям – открываем Filter > Artistic > Plastic Wrap. Настройки выставим Highlight strength – 20, Detail – 11, Smoothness – 8 или на свое усмотрение. Нажимаем ОК. Немного смягчим эффект от фильтра с помощью Filter > Fade or Shift+Ctrl+F ставим opacity около 25%.



Step 9
Выбираем канал water 2, загружаем как выделение и инвертируем его Select > Inverse или Shift+Ctrl+I. Убедимся, что слой water активный и нажимаем Delete. Изменим Blending Mode данного слоя с Normal на Hard Light. Слово станет прозрачным.



Step 10
Далее создадим иллюзию преломления света. Используем для этого Displace Filter. Копируем background Layer и переименовываем его в refraction.
Выбираем water 2 канал и выделяем весь канал Select > All или Ctrl+A. Копируем канал. Создаем новый документ File > New и называем его water displace. Вставьте скопированный канал в новый документ и объедените слои Layer > Flatten Image. Откройте Gaussian Blur Filter и поставьте значение радиуса 6. Сохраните изображение как water displace.psd.
Теперь вернемся к Displace Filter. Вернитесь к тексту. Отмените выделение и и сделайте активным refraction слой. Откройте Filter > Distort > Displace и установите горизонтальный и вертикальный масштаб по 5%; Displacement Map: Stretch to Fit и Undefined Areas: Repeat Edge Pixels. Нажимаем ОК. Откройте the water displace.psd файл. Это придало слову объем.



Загружаем water 2 канал и инвертируем его. При активно слое refraction нажимаем Delete. Получаем легкие блики.
Усилим отражение. Сделаем копию слоя water. Сейчас у нас четыре слоя - background, refraction, water и water copy. Изменим режим смешивания для water copy с Hard Light на Overlay. Объедените Layer > Merge Down или Ctrl+E



Step 11
Придадим глубину воде. Используем Layer Effects. Сделаем активным refraction слой. Открываем Layer > Layer Effects > Drop shadow. Используем настройки: Mode – multiply, color- black, opacity – 40, angle – 135, distance – 3, blur – 6, intensity – 0 c use global angle. (я использовала просто эффекты слоя внизу палитры слоев)



При активном refraction слое выбираем Layer > Effects > Create Layer (или Layer > Layer Style > Create Layer) и получается отдельный слой с тенью под названием refractions drop shadow.

Чтобы достичь эффекта свечения нужно сделать активным refraction слой. Открываем Layers > Effect > Drop Shadow и выставляем следующие настройки: Normal, Opacity: 40%, Angle: -45?, Distance: 5, Blur: 6 and Intensity: 0. нажмите ОК и сделайте отдельный слой Layer > Effects > Create Layer под названием refeactions drop shadow. Что бы не запутаться, переименуем его в refractions glow.

Step 12
В завершении сделаем блеск на каплях. Копируем water 2 канал. Переименовываем его в highlights mask. Размываем этот слой - Gaussian Blur с радиусом - 3. Применяем еще раз фильтр, нажимая Ctrl+F.
Открываем Image > Adjust > Levels или Ctrl+L с параметрами - 200,1.00.255. Далее открываем Filter > Stylize > Emboss со следующими настройками: angle - –45, height – 6, amount – 100. нажимаем ОК.



Снова открываем Ctrl+L или Image > Adjust > Levels. Выставляем значения Input - 128, 1.00, 255. нажимаем ОК. затем открываем Gaussian Blur Filter с радиусом 3. открываем Levels снова с параметрами 130, 1.00, 200. получаем черный фон с белыми тенями.



Далее загрузите highlights mask канал, перейдите обратно в палитру слое и выберите water слой. Добавьте новый слой над ним Layer > New > Layer или Shift+Ctrl+N. Назовите - highlights. Нажимаем ОК. сделайте слой активным и залейте его белым. Уберите выделение.



Final
Если вы еще не умерли, создайте новый слой над highlights и назовите его sparkles. Используя кисть с параметрами – 35 пикселей и 0% жесткости нарисуйте несколько капель на активном слое.
Можно используя кисть Sparkle (Photoshop/Goodies/Brushes folder called Assorted Brushes.abr.) дорисовать несколько бликов на каплях.





Похожие статьи:
- Создание текстуры для заливки
- Работа с Mesh Fill
- Эффект взрыва
- .htaccess - великий и ушастый защитник всего живого
- Как нарисовать сердце
- Мир ярлыков и наклеек в CorelDRAW
- Пулевые отверстия
- Анимэ из фотки


Оглавление | Обсудить на форуме | Главная страница сайта | Карта сайта |

Контакты
Редакция:
[0.001]